Ford Fusion V6 Sport Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
So the car's been throwing a wrench warning a couple of times that clears after about 5 minutes. Sunday was driving the car and the Service Advance Trac warning comes up. Then about 5 minutes later all H3LL breaks loose, and the dash warning lights come on like the Christmas Tree in Rockefeller Center. Park the car, restart it, it goes back to Normal.

Monday morning. Driving the car to the girl friends house to drop it off and pick up my Expedition to go to the airport - 70 mph and it lights up AGAIN, but with even MORE errors. Car is still running, so I get it to her house, grab the Expy and head to the airport. She dropped it off at the dealer for me, and it sounds like some module took a dump, and it going to get replaced.

When I get home, and find out the details I'll post them. But for now, enjoy the pics.....
 

Attachments

·
Registered
Joined
·
1,018 Posts
That's a big " Not good " sign
 
  • Like
Reactions: Rhein

·
Registered
Joined
·
82 Posts
Do you have anything plugged into your OBD port? ELM reader? All of these warnings are consistent with having an issue with your CAN bus. The computers can't exchange information and so they throw errors.

Good luck with your car.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
Nothing plugged in. It has been raining like crazy in Seattle (go figure) so maybe some water intrusion... I'll find out more when get home.
 

·
Premium Member
Joined
·
1,013 Posts
Dat dun got broked!

J/K I hope it's not actually broked.
 
  • Like
Reactions: Rhein

·
Registered
Joined
·
13 Posts
Discussion Starter · #7 ·
UPDATE: Dealer called and had to replace one module (didn't specify which) and is now tracing down OTHER issues. They will have the car for a couple days. They asked if I had driven the car through any deep water (I hadn't). So who knows...
 
1 - 7 of 7 Posts
Top