Front end clicking when turning at low speed - 2017 Ford Fusion V6 Sport Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 08-23-2019, 11:46 AM Thread Starter
Member
 
Join Date: Apr 2019
Posts: 66
Front end clicking when turning at low speed

I’m getting clicking/ticking from the front end when turning under low speed. It’s definitely not a “clunk” sound. It is speed dependent clicking faster as I speed up but goes away as I straighten out the wheel.
It happens in drive or reverse so I notice it every time I back out of the driveway and around our cul de sac.
I did lower the car on steeda springs but that was several months ago and this is a recent problem.
I’m hoping I have time to get under the car this this weekend... but it’s doubtful.

Anyone diagnose anything similar on their sport?
Any info is appreciated!
Hootushead is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-23-2019, 12:23 PM Thread Starter
Member
 
Join Date: Apr 2019
Posts: 66
Also, I did watch the videos JRG posted earlier this month. The clicking sound is similar to his but does not happen when stationary and just turning the wheel and mine seems to click once per wheel revolution.
Hootushead is offline  
post #3 of 4 (permalink) Old 08-23-2019, 12:41 PM
Senior Member
 
Join Date: Sep 2016
Posts: 158
Quote:
Originally Posted by Hootushead View Post
I’m getting clicking/ticking from the front end when turning under low speed. It’s definitely not a “clunk” sound. It is speed dependent clicking faster as I speed up but goes away as I straighten out the wheel.
It happens in drive or reverse so I notice it every time I back out of the driveway and around our cul de sac.
I did lower the car on steeda springs but that was several months ago and this is a recent problem.
I’m hoping I have time to get under the car this this weekend... but it’s doubtful.

Anyone diagnose anything similar on their sport?
Any info is appreciated!
Just diagnosed for this - it's a CV joint and axle. Replacement under warranty. See the other thread - https://www.fusionsportforums.com/fo...ad.php?t=18561
RJA29 is offline  
 
post #4 of 4 (permalink) Old 08-23-2019, 01:08 PM
Senior Member
 
Join Date: Jul 2017
Location: San Antonio, TX
Posts: 202
Garage
Did you recently take off you wheel? I had the same issue. But it went away once I put on new wheels. So to me it was not seated properly on the knuckle.
robhp is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2017 Ford Fusion V6 Sport Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome