Left Front Tweeter Inoperative? - 2017 Ford Fusion V6 Sport Forum
 2Likes
  • 1 Post By bbf2530
  • 1 Post By DaMiFo
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 08-01-2019, 03:57 AM Thread Starter
Senior Member
 
metroplex's Avatar
 
Join Date: Nov 2017
Location: SE MI
Posts: 535
Garage
Left Front Tweeter Inoperative?

I thought I had stuffed ears or it was my imagination, but I've felt in the past (intermittently) that the audio on the driver side wasn't strong. This morning it happened again, and when I parked, I played with balance/fade and found out my left front tweeter wasn't working. It doesn't always happen, but I'd say maybe 5% of the time it would stop working.

Has this occurred to anyone else? Is this a known problem, or am I looking at a possible connectivity problem or just a bad tweeter?

* 2017 Fusion Sport, 12.7 @ 108 mph tune-only (early tune of mine, bad trans settings), full trunk w/ lunch, and dirty paper air filter
* 2014 SHO non-PP, 12.4 @ 111 mph tune-only, all day long with dirty paper air filter and worn out 30k RS-As
metroplex is online now  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-01-2019, 07:33 AM
Senior Member
 
DaMiFo's Avatar
 
Join Date: Aug 2016
Location: CT
Posts: 1,109
Garage
I've never had that happen to me. Did you try the speaker walk-around test (from the APIM's test settings)? It'll test each speaker separate.

Sent from my SM-G975U using Tapatalk

'17 Fusion Sport, Magnetic 401A
(MKZ Cluster / TTR Garrett FMIC / Titanium Tail Lights / Black 10-spoke Escape rims / 5Hundred Painted Badges / Edge Antenna / Mondeo Door Sills / Redline Tuning Hood Struts / Ceramic Tints)
'14 Edge Sport AWD (Daily)
Previous: '10 Focus SES (Totaled, because people text and drive)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DaMiFo is online now  
post #3 of 6 (permalink) Old 08-01-2019, 07:44 AM Thread Starter
Senior Member
 
metroplex's Avatar
 
Join Date: Nov 2017
Location: SE MI
Posts: 535
Garage
Yes I did the Bevel diagnostics and it definitely isn't working. In a fit of rage I decided to diagnostically slap the tweeter housing for troubleshooting reasons and it started to work again. Not sure if I want to pull the door panel to change it... Convincing Ford to do this under warranty may be a Challenge.

* 2017 Fusion Sport, 12.7 @ 108 mph tune-only (early tune of mine, bad trans settings), full trunk w/ lunch, and dirty paper air filter
* 2014 SHO non-PP, 12.4 @ 111 mph tune-only, all day long with dirty paper air filter and worn out 30k RS-As
metroplex is online now  
 
post #4 of 6 (permalink) Old 08-01-2019, 08:01 AM
Senior Member
 
Join Date: Sep 2018
Posts: 118
Quote:
Originally Posted by metroplex View Post
Yes I did the Bevel diagnostics and it definitely isn't working. In a fit of rage I decided to diagnostically slap the tweeter housing for troubleshooting reasons and it started to work again. Not sure if I want to pull the door panel to change it... Convincing Ford to do this under warranty may be a Challenge.

Hi metroplex. Warranty coverage will not be a challenge at all if you bring it in for service and it is not working at the time. The only possible problem will be the dreaded "Could not verify/duplicate customers concern", if it is working properly the day they check it.

A good plan would be to stop by the Dealership one day when it is not working, so you can demonstrate and have it verfied. Then you will have less worries about it working the particular day you have an appointment.

Let us know how you make out and good luck.
ArthurUSCG likes this.
bbf2530 is online now  
post #5 of 6 (permalink) Old 08-02-2019, 12:07 AM
Senior Member
 
DaMiFo's Avatar
 
Join Date: Aug 2016
Location: CT
Posts: 1,109
Garage
Next time it's not working, take a video of it not working (even of the car doing the walk-around test), then try smacking the door again to show the difference if it starts working. Proof like that is usually good enough (for small issues like this) to get them to look at things under warranty.

I blast my radio a lot when I have the windows open on the highway, and I don't have any issues (23k-ish miles so far).

I have however noticed that our ex-lease '16 Escape Titanium always had a slightly muffled rear-passenger tweeter when the volume was cranked, as does our current leased '19 Edge (rear-passenger side, tho). So it wouldn't surprise me if these are just poor quality tweeters that tend to have issues.

Are you past your 36k miles b2b warranty?
ArthurUSCG likes this.

'17 Fusion Sport, Magnetic 401A
(MKZ Cluster / TTR Garrett FMIC / Titanium Tail Lights / Black 10-spoke Escape rims / 5Hundred Painted Badges / Edge Antenna / Mondeo Door Sills / Redline Tuning Hood Struts / Ceramic Tints)
'14 Edge Sport AWD (Daily)
Previous: '10 Focus SES (Totaled, because people text and drive)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DaMiFo is online now  
post #6 of 6 (permalink) Old 08-02-2019, 04:00 AM Thread Starter
Senior Member
 
metroplex's Avatar
 
Join Date: Nov 2017
Location: SE MI
Posts: 535
Garage
I'm not sure if the Edge used the same tweeters, but the Focus, Fusion, and Escape, if I recall, shared the same tweeters (front and rear). The local dealerships want me to schedule an appointment 3-4 weeks out and to leave the car there for at least 1-3 days due to the amount of vehicles in their queue. I tried to get them to fix the door module and ACM issues without an appointment, and they said I'd have to leave my car there for at least 4 days. I told them it takes about 15-20 minutes total as it is pure software upgrade only. Anyhow, the tweeter seems to be working now, so I will just keep an eye on them. I was tempted to buy the MKZ tweeter as it is supposed to be a "Revel" system.

* 2017 Fusion Sport, 12.7 @ 108 mph tune-only (early tune of mine, bad trans settings), full trunk w/ lunch, and dirty paper air filter
* 2014 SHO non-PP, 12.4 @ 111 mph tune-only, all day long with dirty paper air filter and worn out 30k RS-As
metroplex is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2017 Ford Fusion V6 Sport Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome